Chrome turning Chinese


#1

This year I don’t have an office, so I’m mostly using a laptop and wireless internet, which is a PITA. Viruses, application problems (“Excel has stopped working and needs to close. Windows is looking for a solution to this problem blah blah…”)

One potentially terminal problem is that my favored browser Chrome is translating (I assume) some of the texts of some websites into Chinese. Started with a US-based online STEM course and has now “spread” to my yahoo email, rendering it unusable.

I don’t read Chinese, I’m not about to learn, and since this is presumably some kind of machine translation its probably wrong anyway.

I have the browser language set to English, of course. Clearing the browser history doesn’t seem to make any difference.

Running Windows 10. Microsoft Edge is on it but doesn’t seem to work properly and sometimes won’t start, though I suppose I could try another browser.

Had a search on the internyet but didn’t find anything useful.

Suggestions?


#2

To turn off Google auto translation:

  1. Open Google Chrome browser.
    
  2. In the top right corner of the browser window, click the Chrome menu (hamburger or 3 dots).
    
  3. Select Settings.
    
  4. Scroll down and click Show advanced settings.
    
  5. In the "Languages" section, uncheck "Offer to translate pages that aren't in a language you read" box.

#3

Thanks for the quick reply

That seems to be turned off.

Strictly speaking it wouldn’t make sense since its not “offering” to do anything, the pages are originally in English, and I have my language set to English, but of course (broken) software isn’t necessarily going to make sense.

Are there any browsers with a “MIND YOUR OWN BUSINESS AND JUST DO AS YOU ARE FUCKING TOLD” setting?


#4

Firefox is my default browser. I have chrome installed by don’t use it unless I have to. Some sites for some reason only works with chrome.

Although Chrome does ask you if it should auto translate a site the first time you visit it. Somehow chrome got the input to auto translate for those sites without you realizing it.


#5

The translation is probably Google Translate so switching away from Chrome will (very) likely fix it.

I have been using Opera lately. Seems to work on everything. Has integrated ad blocker. Integrated free VPN if you want to watch videos out of region. I think its based on chrome. Seems fast.
I have been using Opera Mini for years on mobile devices for its data compression and I think I decided to try it for the VPN.

Good luck.