Can't access link

Link does not work.

Works for me.

So maybe it blocks hinet?

No. I am on Hinet right now.

Then I don’t know…

Downloaded it earlier. Impressed so far. Thanks for the heads-up.

Works fine for me

Maybe it worked before, because it does not work on both my browser or my cell phone, so it’s not a ISP blocked issue.

Maybe you are viewing cached version.

Or they block all IP outside of the US.

First time I viewed it was just now so definitely not cached. Just tried on my phone which is on CHT 4G as opposed to my cable internet and it works fine too.

Then I don’t know why it does not work both on my phone and on the browser. I even entered it into a broken link checker and it isn’t giving me anything conclusive.

And you sure you are not using a VPN?


I get this error, from both my phone and my computer, regardless of what browser I use:


1 Like

Did you type the address or click on the link above?


You’re missing a “%”

I got it here, in Indonesia, just fine.

See if you can reach

I did.

It has nothing to do with address. That server is not accessible to me at all. I tried just accessing the base domain and it’s giving me the same error.

For whatever reason, it’s blocking me.

Are you using a VPN?

Weird, are you using your cellphone data connection or wifi through the same router as your computer?

If you’re on dynamic IP try restarting your router and get a new IP address

Not at all. I wanted to see if I could try it with a VPN to see if it works.

Just clicked on it, not working for me either.

I’m using a VPN though.