Firewire card works...but no camera detected

Yet another episode in my battle to get my computer working. After the recent troubles I had with Norton and other things, I decided to upgrade and start fresh with a new Asus P4P800 motherboard and Intel P4 3.2 setup.

So far, so good.

Now, however, when I plug in my video camera to the firewire ports…nothing. No detection of anything, despite the fact that the system hardware monitor says the card is plugged in and working properly. I’ve tried different cables, different slots, and no dice. I’m wondering: is the firewire card not up to working with the new CPU? Or is it a settings problem? If so, which settings?

Right Click My Computer. Hardware Tab takes you to the Device Manager. Look for Firewire. Then see if there’s anything there. If there is and there is a problem there should be a yellow alert. Look to see if the drivers are working. If not reinstall them or get fresh ones from the Net.

If the hot-plugging of a FireWire/USB device fails in Windows XP…

To hot-plug (hotplug) means plugging in the drive while the computer is running instead of when it is shut down.


You have a computer running Windows XP with a FireWire (IEEE 1394) adapter card installed Whenever you hot-plug a new external DVD-RW drive into one of the card’s FireWire ports, it doesn’t appear under My Computer. You have tried restarting the computer and reattaching the DVD-RW drive, but that has failed. You therefore want to know if there is remedy for the problem.


First, check that your FireWire adapter is installed and functioning properly. You can check the Device Manager by right-clicking My Computer and choosing Properties. On the Hardware tab, click Device Manager. If your FireWire Controller has an exclamation mark beside it, then you need to highlight the entry, remove it, and then reinstall its drivers.

If your IEEE 1394 FireWire card is installed and is functioning properly, you should know that Microsoft has recognised that this fault can occur when hot-plugging a FireWire or USB CD/DVD-ROM drive into a computer running Windows XP. [color=red]Microsoft says that the fix for this is to install Windows XP Service Pack 1.[/color] Note you may require the same fix if you attach a digital video 1394 device that supports non-S100 data rates, and you see only a black window in Windows Movie Maker.

The device manager says nothing is wrong with the firewire card, that is is installed and working properly. No problem there.

I downloaded and installed Service Pack 2, which did not fix the problem.

This might sound silly; but did you switch ON the camera once you connected it?

Yes, I tried it with the camera on, switching the camera on after connecting, before, and every combination I could think of.

You might get really lucky like me and fiddle around for weeks to get the laptop to see the camera by firewire and then have it hang every time I tried to download any pictures.

I now have an eMac

I have a similar problem on Win2K with USB-pluggable hard drives. For the typical small flash drive, no problem, works right nearly every time. For the hard drives, I must:

  1. open “Windows Explorer”
  2. open the “My Computer” subtree so that I can see the drives
  3. plug the drive in, wait for nothing to happen
  4. unplug the drive
  5. plug the drive in again. Wow, a miracle occurs, Win2K actually recognizes it, woohoo.

F*&#$ing Microsoft. . . .

Anyway, give it a shot. Can’t hurt, might be very amusing.

User error
USB and FireWire connections use a different protocol.
FireWire is a network connection, USB is a bus system like IDE.

[quote=“robi666”]User error
USB and FireWire connections use a different protocol.
FireWire is a network connection, USB is a bus system like IDE.[/quote]

I never mentioned USB. I was talking about firewire the whole time. Do people capture digital video with USB? The horror! (Although I guess USB 2.0 might be fast enough for such things)

In any case, I got it to work by switching out the firewire card for another one a friend had but wasn’t using. Taking out my Internet card seemed to help, but now my adsl, hooked up directly to the new motherboard, is down to dial-up speeds for some reason. If it’s not one thing it’s another.