Google.com (not .tw) in my url bar

So in my bookmarks. google is set to google.com, but in Chrome, I often just use the address bar / url bar as the Google search. However, it always directs to google.com.tw. Does anyone know how I can set this to go to .com?

Mine goes to .com, so there must be a way. I Can’t see anything in the settings that would explain it though.

Right click the address bar, the last option is ‘Edit search engines’. Then check your google.com box and make it default.

… and pray!

It’s all about cookies … the settings are saved in cookies …

Chrome does this to me if i have cleaned out the browsing history, same for yahoo, youtube and a bunch of other sites, nearly always there is an option to go to the English version, For google its under the search box on the right. Once you do it once, it never goes back to the Taiwanese version, unless you clear out your browsing history.

[quote=“Belgian Pie”]… and pray!

It’s all about cookies … the settings are saved in cookies …[/quote]
yes, but ever since I did that, it does not go to .in.

Try typing “www.google.com/ncr” as your home page tab, or whatever one does in Chrome.

That’s what worked for me in Safari and Firefox, and they stopped taking me to the Taiwan version. It somehow resets the cookies for English Google.

I had this problem too in Chrome, and this solved it:

[quote]Go into “Manage Search Engines” on the “basics” tab in prefs and create a new one.

Enter these values:

Name: Google English (Or whatever)
Keyword: google.com
Url: google.com/search?{google:RLZ}{google:acceptedSuggestion}{goo gle:originalQueryForSuggestion}sourceid=chrome&ie= {inputEncoding}&q=%s

Set as default search engine.[/quote]
chromeboard.com/showthread.php?t=12982

Right click the address bar, the last option is ‘Edit search engines’. Then check your google.com box and make it default.[/quote]This only works when you’re logged into Google Chrome. That’s what I do. I log in and I select “Keep me logged in.” It keeps me logged in even when I restart my computer so I’m always on the .com version of Google.

I just tried what Kea suggested and that seemed to work, too. I may not need to be logged in anymore. We’ll see.

I didn’t know I could just use the address bar to search Google in Chrome, by the way. It’s very nice to know this shortcut. :slight_smile:

On a related note, how do I keep automatic localization from appearing in my iPhone search/map/app results? I’ve gone through the usual rigmarole, but Chinese result continue to appear.

You mean like how my address book keeps assuming that everything I want to see on a map is in Canada, even though Taiwan is entered as the country? Yeah, I’d like to get rid of that too.

[quote=“Kea”]I had this problem too in Chrome, and this solved it:

[quote]Go into “Manage Search Engines” on the “basics” tab in prefs and create a new one.

Enter these values:

Name: Google English (Or whatever)
Keyword: google.com
Url: google.com/search?{google:RLZ}{google:acceptedSuggestion}{goo gle:originalQueryForSuggestion}sourceid=chrome&ie= {inputEncoding}&q=%s

Set as default search engine.[/quote]
chromeboard.com/showthread.php?t=12982[/quote]
I set my url as google.com/search?q=%s and it solved the problem beautifully. I’m happy! :slight_smile:

[quote=“maoman”][quote=“Kea”]I had this problem too in Chrome, and this solved it:

[quote]Go into “Manage Search Engines” on the “basics” tab in prefs and create a new one.

Enter these values:

Name: Google English (Or whatever)
Keyword: google.com
Url: google.com/search?{google:RLZ}{google:acceptedSuggestion}{goo gle:originalQueryForSuggestion}sourceid=chrome&ie= {inputEncoding}&q=%s

Set as default search engine.[/quote]
chromeboard.com/showthread.php?t=12982[/quote]
I set my url as google.com/search?q=%s and it solved the problem beautifully. I’m happy! :slight_smile:[/quote]
you didn’t try my solution??? :frowning:

You mean like how my address book keeps assuming that everything I want to see on a map is in Canada, even though Taiwan is entered as the country? Yeah, I’d like to get rid of that too.[/quote]

Hit the circle under the compass in a location-aware browser and accept when it asks to know your location. When it’s blue, maps is location-aware and works similarly to how it does on a phone or tablet.

In Settings → General → International what are your Language and Region Format settings? Also what is the order of your keyboards?

Language -> English
Keyboards -> English, Chinese Traditional Handwriting, Chinese Traditional Zhuyin
Region format -> Canada

So where exactly is this “url bar”, anyways?
Do they have Happy Hour?
Most bars now have free wireless, they should let you connect to Google, especially if you’re drinking.

I think Mr. Man is holding out on us regarding his favourite new watering hole…

google.com/support/websearch … answer=873

Says: Bookmark google.com/ncr. This is an alternative web address for Google.com that always takes you to Google.com without redirecting you.

[quote=“Jaboney”]Language -> English
Keyboards -> English, Chinese Traditional Handwriting, Chinese Traditional Zhuyin
Region format -> Canada[/quote]

This is purely speculative, because I didn’t change anything and always get the English Google results unless I type any character in Chinese.

My setup is yours without the handwriting, with Traditional Pinyin as secondary and with Region Format set to USA
Also, I log off of Google in the browser

There doesn’t seem to be any loc settings in the Browser settings.

Any dice with that?