Hanyu Pinyin input for XP

I’m having trouble getting my computer, recently upgraded to XP, to let me use Hanyu Pinyin to input traditional Chinese characters. It seems that, according to many websites such as http://www.ust.hk/itsc/desktop/pc/windowsxp/chinesefaq.html#hanyu, that my menu is lacking the “Microsoft New Phonetic IME 2002a” choice needed to allow one to input Chinese in HYPY. Is there any way to work around this? I’ve downloaded Microsoft’s language packs, all to no avail.

Open the Regional and Language Control Panel. The second tab is for languages. Make sure the “Install Asian languages” box is checked. Click details and then add. Look for Chinese Taiwan. Then click for IME and look for New Phonetic.

HTH

As I said, that choice is not available on the menu in my system. The “Install Asian Langages” box is greyed out, but it is checked. The menu gives me all sorts of other Chinese input methods, Changjie, etc., but nothing with Hanyu Pinyin or the Microsoft one either. This is quite irritating.

in that ccase you already have it installed…wait let me see…assuming that you have chinese (taiwan) in your language bar, click on the lang bar ‘eng’ icon, click ‘show lang bar’, select chinese taiwan, go to tools, then properties…you will have a settings box open up…check that intelligent ime is checked…then move to the input tab…there you can select from an array of input methods. i hope that clears things up.

Paogao:

I have the 2002a input on my machine, but it is not an option in that dropdown menu. I’m not keen on removing it, as I may not be able to reinstall it.

On a related note:

I have found the program to switch between ENG and CHN menus.

The page says I may not paste the link here, but just search microsoft.com for Traditional Chinese IMe.

office.microsoft.com/downloads/2002/imecht.aspx

Are you logged on as an adminstrator?

Thanks, Southpaw and Alleycat, I think that did it. Or something. Anyway,

Paogoa:

If it is not in the menu, it means it is installed. I just installed “Phonetic” and once I did the choice disappeared from the menu. 2002a is not i believe a choice. Just install “Phonetic.”

I have a similar problem in WIn 2000 PRO…the option for Hanyu Pinyin simply is NOT included (English version) although I have installed both the Simplified and Traditional Chinese IMEs from Micro$oft. Any way around this? I have the so-called “natural input method” software but it’s awful…hangs the system and causes strange codings.

Don’t get confused between Office XP Tool: Global IME (Traditional Chinese) and Microsoft Phonetic Input 2002a. It’s two different things.

Microsoft Phonetic Input 2002a is native to the OS environment, and you can use it across the system. But Global IME is just another program that allow you to type Chinese on certain Office Application (IE, Outlook, Word, Excel, etc), but you cannot use it to type systemwide.

Make sure you have Microsoft Phonetic Input 2002a installed on your XP english. Here’s the step by step:

  1. Select Control Panel / Regional.
  2. On the system language settings / General Tab, make sure Chinese Traditional is checked. If not, insert WinXP CD, check the CT option, and click OK. The system will copy necessary nls and inputsystem from the CD.
  3. Reboot your system
  4. On Input Method Tab, Click New, Select Chinese and Microsoft Phonetic Input 2002a from the combobox and click Apply/OK.
    The phonetic input should be installed now and you can switch to it using Ctrl+space or Ctrl+shift, if you cannot switch. Check the hotkeysettings.

Personally, I think Chinese input system on XP is a bit buggy. It’s not as tamed as on win2k. sometimes the shortcut just won’t work or the input bar’s just gone to oblivion.

regards

ax

Southpaw, many thanks. I’ve been meaning to figure out how to do that.

It seems to work in Trillian and other chat programs, as well as on online forums. So far so good. Thanks for all the information.

[color=red]I don’t HAVE XP[/color], I have Win2K!!! How can I do this with Win2K? Does anyone know??

well, i could do exactly the same same thing when i had windows Me a while back, and that is basically the same as win 98. so, i suspect that the same instuctions, save for a menu difference or 2, will for for you iron lady. do you have the IME?

As I’ve said, I have both IMEs (simplified and traditional), but I’m running English Win2K Professional. I can’t find any option such as those described above. There are lots of possible input methods in the Traditional Chinese box, but no Pinyin. (Not even TongYong, not that I would stoop so low…! :shock: )

i dont believe that you followed MY directions…stay clear of the control panel and language menus, it can be done from the language bar…the bit where you can select your language. that is unless 2k is different from all other windows versions…xp is basically the same as win2k…and professional edition has nothing to do with it

I am going to have to start writing correct sentences with capitalisation and punctuation.

Nay, dear Southpaw, I did follow your directions…but the option you mentioned doesn’t appear on the language bar thingie. Very annoying indeed.

wow. learn something new every day. i already had new phonetic set up on my comp, but was using it with a bopomofo keyboard. didn’t know you could go into the properties and set the keyboard mapping to hypy. thanks for the helpful tips on this thread!

Looks like things may be a little different in W2K.

Try here fisrt
Looks like the same thing here

Let us know if one of these works. If not, I’ll try to find more info.