How do I stop YouTube from recommending me Taiwanese YouTube videos?

How do I get around YouTube recommending me Taiwanese YouTube videos?

I guess I could VPN to another country, but don’t want to do that.

Surely YouTube must have an option for disabling non-English content. I just can’t find it.

On the browser version of YouTube you seem to be able to do this by changing your country to somewhere not Taiwan, but doesn’t have the same effect in the Android TV version.

You must be logged in.



Settings > General

So I just tried that, on browser it works, but on the Android TV app it resets to Taiwan every time the app gets restarted. However, I’ve found another solution, I just went through all the Chinese videos on the home screen and marked them all as not interested. Now all English!

Great job Google! :rofl:

This is why I don’t even look at recommended videos. I just look at my subscription video list.

1 Like

Ensure your accout is set to English.
Ensure your OS is set to English, I set everything I have to English UK cause they spell things correctly. (kidding)

Watch a tonne of English videos that you like. keep watching them to get your preferences established.

As @slawa mentioned, set Location to UK or other English country.

1 Like

I do use the “don’t recommend me this type of video” function every once in a while. The Taiwanese content recommended is just a small percentage, so it does not bother me.

I am more annoyed by some of the ads that always play. Right now it’s Food Panda ad nauseam. Also the very generic and fake Facebook ads become extremely irritating after a while.