Jumpy Windows XP -- Spaz attack!

My Windows XP constantly has a spaz attack. My cursor seems to flicker causing my whole screen to flicker and a complete system slow down. It doesn’t happen everyday and it usually goes away after awhile otherwise I need to reboot. Anyone else have this problem or have any ideas what’s going on?

It might be that your mouse is going bad, and is sending lots of spurious garbage “movement” to the machine.

It’s also possible that you have some sort of virus or backdoor on your machine. Might want to scan the drive and keep an eye on your network traffic light.

If things are flickering, or the screen goes garbled, that sounds like like video card, make sure it’s plugged in well.

Sometimes my laptop does it when using the USB mouse but the laptop thinks, someone has touched the touchpad (as seen from the tiny icon on the task bar).

No viruses as Norton scans my machine every night. As for a faulty mouse I suppose it could be but it’s only two years old and it’s a Logitech.

For example last night before I went to bed it was flickering up a storm, this morning there’s no problem. And the whole thing started right after I installed XP, I never had this problem before so I don’t think it’s anything to do with the mouse, unless it’s not compatible with XP, but I’ve upgraded the driver. My screen doesn’t go garblie, just flickers, the colors don’t change, theres no lines or distortion, just quick flashing like it’s having a seizer.

is it a wireless one by chance?

wireless computer? No. Wireless mouse? No

Still reckon it’s the video card, or drivers. Hardware cursors and stuff. I’ll have a look to see if there’s a way to turn it off.

Again it’s caused by XP, or certainly seems like it because I also have Win 2000 still installed on my machine, if I use win2K it doesn’t happen.

[quote=“JeffG”]Again it’s caused by XP, I also have Win 2000 still installed on my machine, if I use win2K it doesn’t happen.[/quote]That could be the video drivers then, try this I don’t know if this will disable hardware cursors or not, but give it a go:

Go to “display” in control panel. or right click on the desktop.
Then “Settings” Tab.
Then “Advanced”
Then “Troubleshooting” Tab
move the ‘Hardware acceleration’ slider to the left.

See if that stops it flickering.
This isn’t a solution because it turns stuff off that you want on, but might show me what’s broken.

I’ve moved it all the way over to the left disability all acceleration, I’ll see what happens in the next week or so. It doesn’t happen ever day, seems only to happen when I have a lot of windows open or try to do something too quick, so you may have just hit the nail on the head, let’s see what happens. Thanks for the help!

Make sure your handphone isn’t anywhere near your computer.


I had a problem like this for Windows XP. I discovered it was because I installed a graphics driver (SiS) that was on the Microsoft website. It wasn’t really necessary but I thought it would be a good thing to do. For some reason there is a conflict between the GeForce driver and the SiS motherboard graphic driver. But there is no way to uninstall the SiS driver.

I read a bunch of stuff on the internet, and about all I found out was to do a clean install of Windows. I did that, and now I can choose which system to install at startup. I can still load up the old system that hangs every so often, giving me a black screen and disabling the computer for 4 seconds. But I only do that when I want to use some software that I haven’t reinstalled onto the new system.

I suggest you do a clean install of Windows XP, and don’t update the graphics drivers unless you’re sure they are the right ones.

My video card is built into my mother board if that helps any. If I did indeed install the SIS file is there anyway to remove it without reinstalling XP? I’ve already reinstalled it twice in the last few months and now I have tons of software I don’t want to reinstall again… Leave it to Microsoft…

After I installed that unnecessary SiS graphics driver, I looked at
Start/Control Panel/System/Hardware/Device Manager/System Devices/

I was able to determine that was the driver by disabling it… but I decided to do a clean install rather than mess with it, since I’m not sure I should change system hardware settings at random.