Mac OS X Question: How to post in Chinese?

I’ve gotta be doing something wrong here…every time I try to post something online in Chinese I get gibberish. How do y’all manage to do it in OS X?

The switch for English --> Chinese is the Apple key and space. Then type away… works for us.

I just tried that and it worked.

Alternatively, go to your system preferences, select languages, then select either ‘language’ or ‘imput’.

If you select ‘imput’ in system prefs, it allows you to select Traditional Chinese as one of your imput options. I have both Aussie English and Traditional Chinese selected. Now if you look up on the top right hand corner of your browser, you’ll see a little Aussie flag (or US one if you chose US English). That means your OSX is set to its language. Pull that down and you also have the option of switching between Aussie English and Traditional Chinese at your own free will.

If you select ‘language’ in system prefs, it’ll change your browser to Chinese, French, Spanish (whichever you select) the next time you open your browser.


用Camino沒甚麼問題,but I can’t post in Chinese using Safari

Aha…that must be it, I’ve been using Safari. Thanks for the help, guys.

Also, is it just me, or has MS Word 2004 improved a lot in terms of handling Chinese input? In previous versions typing in Chinese was such a pain in the bootyhole that I always ended up drawing up the document in Mail, then cutting and pasting it into Word. No need to do that anymore, and the font smoothing does wonders to make the characters nicer to look at.

Yes, Office 2004 is much better at handling Chinese text than before. However, their “Unicode support” is still a bit lacking

I still can’t write in Chinese. I have my language set. So I can click on Traditional Chinese in the upper right corner. I choose Pinyin, but when I type it gives those weird characters, althought IE is set to traidional chinese.

I am running OSX.

Does anyone know how to do this? ? 回

i’m running osx too and it took a little while for me to learn how to type chinese, but now I am okay with it

I’ve got it set on traditional chinese and pinyin (id have it on han yin except I can’t remember the keyboard off the top of my head) and it works easily for me

if it’s still not working, maybe take it to the store and have somebody look at it for you?

by gibberish do you mean stuff like

Encoding won’t affect being able to type chinese; only reading will matter.

Anyone with problems, can you type chinese in any other app? Maybe you have missing fonts.

I’ve posted things in Chinese with Safari before on Forumosa. You need to first make sure you set the text encoding to UTF-8 BEFORE you start typing in Chinese. This means you have to essentially reload the page in question with the correct encoding. Type away … I had the same problem until I figured this out.

In most programs (in this case Explorer) you can view the chinese text by vy selecting the view menu and then character set…choose traditional chinese…or whatever verion you want to read… this will allow the characters to be seen your monitor. Note, you must set up your text input preferences too. Do this by selecting preferences for the Explorer drop down menu, next select languages/fonts, then select add. Add the appropriate language from the selection.

In word select all the text, then change the font to a chinese text font. Obvioulsy this will not work if you do not have any chinese fonts installed.

hope this little bit helps.


如果 我用 safari, 我不會
如果我用 firefox, 我會