Need someone to setup my router

I have tried everything to setup my Buffalo router. I had it set up but was having trouble getting it to connect to the internet. Then, Win7, which listed it as a Buffalo router, then showed it as a Ralink router, after which the PIN stopped working (I decided to start everything from scratch, so needed the PIN again). Now I cant do anything with it at all. The security light keeps flashing too. Can anyone help or know anyone who can?

Solved. A small button on my router seemed to get through all the problems I was having. Now my laptop recognizes my router and I am set up. My only problem now is that my desktop has no wireless adapter. When I went to Guanghua, I couldn’t find a place that sold a USB apapter. I only need it to connect the computer to my wireless printer. Anyone know where I can get one?

Are you connecting the desktop to the router via wired Ethernet? If so, you shouldn’t need a wireless dongle for the desktop, as the printer connects to the router and then from there via cable to your PC.
Otherwise, check out the Sunfar store near the computer market, it’s underground by the TV building, they have tons of different dongles.

Got a Buffalo router a while back and I can’t say I’m overly impressed by the performance. It works fine on the floor it’s on, but I barely get any signal downstairs or upstairs… I guess it’s a cheap model, but still, 802.11n should be better than this. The only good thing is that you can install DD-WRT on it, as Buffalo’s router software is pants.

I spent last night trying to set up my wired xp system to see the wireless, but to no avail. I have it plugged into the router, and the modem connected to the router’s internet socket. When i try to use to enter the router’s set up (works on my laptop), I get a “page not found” notification. When I use the setup network wizard on XP, my computer doesn’t even see the network. Any ideas on where I am going wrong?

Broken network cable?
It’s possible that your PC is set up to use static IP address that is not on hte 192.168.11.x range.
Try a quick thing, open a command prompt window (start, run, cmd and hit enter), type ipconfig and see what comes up. If it’s anything but 192.168.11.x then you need to change either to DHCP or a static address in the same IP range. I can’t really remember how to do all that in XP, but it’s done in the network configuration under the network card settings.
If it’s still not working once you’ve set it to DHCP, try opening a command prompt window again and type ipconfig /release and then ipconfig /renew and it should work.