Problem using Chinese Telnet BBS with XP

I just installed Windows XP. I was using ME before. MY wife uses this BBS a lot:


The problem is, it won’t start anymore. Other BBSs from this page: … ndex2.html

will open, but the Chinese is gibberish. I’ve loaded all the languages from XP and got all the Explorer Chinese settings on, but still no luck.

Anyone got any idea how to solve this problem?

Go to ‘Advanced’ tab in ‘Regional and Language Options’ and chose chinese(Taiwan) in ‘Language for non-unicode programs’. That should let programs, other than office and explorer, display Chinese

I’ve just worked out how to enter Traditional characters in Pin-Yin in XP, let me know if you need that too.

Thanks Matthew, but I already tried that. I’ve got all the Chiense options from the control panel turned on, and still no luck.


Strange… it worked for me… When you say the Chinese is gibberish, do you get gibberish Latin letters and funny symbols, or gibberish chinese characters ?

Try downloading and using a telnet/ssh client called PuTTY. It works with the BBS you mentioned and Chinese XP. Or are you running an English version of XP? Then you might try SimpTerm. I can’t test that for you because I don’t have an English version of XP handy.

I also run an English XP with Chinese Taiwanese language support enabled and can’t see the Chinese characters, only graphical symbols / latin characters.

I guess the problem is that it’s English XP. I think I’ve got all the languages loaded, so I can read Chinese on web pages, etc, but still have a few problems (ie Chinese characters are (latin) gibberish), which are:

  1. The Telnet I mentioned above - gibbeish
  2. Trying to load Chinese programs, readme files - gibberish
  3. Names of Chinese programs I try to load - gibberish
  4. My wife’s Chinese input method, which is not one of XPs IMEs - I try and start the downloaded program it says it can’t run it because it’s not a traditional Chinese environment

Does this mean that if you want full Chinese you really have to run Chinese XP? Does anyone do this with the English patch that turns the Chinese XP into English? I’d really like to set up XP so I can use it fully in English and my wife can use it fully in Chinese. Or is my only option to run them both, and can this cause problems?


My suggestion is you have a dual boot on your PC.
one that boot to ChineseXP and another to EnglishXP
that should satisfy your current need


I use English XP, and I can see Chinese works in almost all places, including telnet and readme files, I’m not sure how I managed it if everyone else seems to have problems… Dual booting with Chinese XP seems overkill and more trouble than it’s worth, especially seeing as I can see Chinese in English XP, honest :blush:
I’m happy to have a look for you, try and see what we’ve done differently

Looks like it was my mistake. I got it to work by trying what you said Matthew

[quote]Go to ‘Advanced’ tab in ‘Regional and Language Options’ and chose chinese(Taiwan) in ‘Language for non-unicode programs’. That should let programs, other than office and explorer, display Chinese

I know I did try that before, but maybe I changed it back to English again before I restarted or something, because it didn’t work then, but when I tried again now and restarted it worked. Now I can use Telnet in Chinese (well my wife can) and managed to install her Boshiamy Chinese input program, which wouldn’t run before, so all is sweet.

Well nearly all. Nero doesn’t want to reinstall, which is a real bugger. it thinks it’s still there, but it’s not. Back to work.