[Solved] How to setup Chungwa Telecom router to access LAN server from outside?

Hi everyone,

I have a 20MB Internet (VDSL2) connection at Chunghwa Telecom.
I set-up my connection to use only one static IP (instead of the common 8 dynamic IP address).
Now I would like to be able to access my server from outside.

The problem is: I can’t get the router provided by CHT (a D-Link DSL-6641k) to route the traffic from outside to my server address. I cannot even ping it!

First of all, I found on some Taiwanese forums that you can unlock a lot of features if you use the following login/password when connecting to your router: cht/chtnvdsl (n stands for north, if you live in Taichung use cht/chtcvdsl, and if you live in Kaohsiung use cht/chtsvdsl, from what I understood).

In Setup > WAN Setup, I see two connections:

Connection 1
Connection type: Bridge
Mask: -
Gateway: -

Connection 2
Connection type: PPPoE
WAN IP: 1.34.xxx.xxx (my static IP)
Gateway: 168.95.xxx.xxx

Anyway, the main menu I guess I should be working on is in Advanced > Virtual Server.
In this screen, I can set up how the router will route the traffic coming from the Internet IP.
First question: When creating a new rule there, should I use Connection 1 or Connection 2?

I tried with both, using the correct port I needed, rebooted the router, etc., nothing.

Then I saw the Advanced > DMZ (Exposed Host).
I activated it, put my server’s LAN IP address, rebooted the router… nothing.

How can I set-up this bloody router to allow me to access my server from outside?

Thanks in advance :slight_smile:

Hi Pierrrre,

Interesting project you’re attempting.

If I were you, the first thing I’d be looking at is making sure that the static IP address really is correct. Above, you mentioned:

WAN IP: 1.34.xxx.xxx (my static IP)

Once you’re online, you can go to a number of web sites to check your IP address, such as whatismyipaddress.com/. The result should match your static IP address. From outside your network, you should be able to ping this address, unless the router has been configured to block pings.

If the address is right, next thing is to be sure your web server software is up and running and configured to allow access from the outside.

Make sure your firewall isn’t blocking port 80 (http) or port 443 (https). The active ports may be discovered from the command line by typing: netstat -a.

I’m not an expert and can’t say too much more than that. I run a server on my own Linux box just to test my own web site, but I block access from the outside.


Thanks for your help!

I managed to get it to work:

In Virtual Server, simply use Connection 2, and route it to my LAN server IP with the correct ports.

Actually it might have been working before, but the tests I was doing was unsuccessful… Now it’s working fine.

Cheers :slight_smile: