Taiwan's Digital COVID Vaccine Certificate (數位新冠病毒健康證明) [TO BE DISCONTINUED AT THE END OF MAY 2023]

Yeah that one character last name indeed looks like a chabuduo program logic result. Or having the “English” name in a database field where only the mandarin name is expected…

I guess this should work OK with all apps that correctly use the fnt/gnt.

Not 100% correct, though:

Compared to the “native Taiwanese” one I decoded: the given name INGWEN should be in gnt not fnt, and there should be the < spacing character between the two characters ING and the WEN.

Yes right. The Taiwanese Certificate looks different. Because their English names are standardized translated. And the separator < should be there


You guys is smart.

Very glad to see your work on forumosa. With luck, @au will take note, and hopefully get this tweaked.



Audrey is already helping us looking into this problem.


Tiny update: the responsible people have been informed.

Maybe they will need more data (actual QR codes). In case that happens, maybe some of the contributors here could kindly email screenshots of their QR code and name on the PDF to a certain government email address. Or, maybe someone writes mandarin well and could step in in case this issue is hard to explain in English… let’s see.

In the meanwhile, here is a glimpse into the ever so slightly related German internet meme above. Or use google translate to enjoy the complete saga of #TechnicianHasBeenInformed


Most likely the problem lies within software used by different government agencies.
Sometimes the English names of foreigners are saved in the field where the Chinese names are supposed to be.
That might be human error or a workaround if a foreigner does not have a Chinese name yet, but the software requires it. :man_shrugging:

Those are just some assumptions on my part.


The MOHW import logic from NIA has been updated — please try again and see if it improves.

Since the data source does not distinguish between “fn” and “gn”, for now we’re just putting everything in “fn” field and leaving “gn” blank.


Tried it just now. Yes it has changed from previously, and the name field is as follows, spread over two lines -


on the first line is my chinese name but shown in English and in lower case
on the second line is my English name in all upper case with one blank space between each.


Thanks a lot for the quick reaction and the heads up!

As far as I can tell “everything in fn and leaving gn black” is not going to cause any trouble abroad. Of course if the source data is not clearer, then that might be a good enough practical way :slight_smile: As long as the main issue with the “one character last name” gets solved.

Sooo… now suddenly my mandarin name shows up (it didn’t before) and I get the same thing as @yinggeaussie… and it is the same as @slawa already saw in the previous version of the certificate:

"nam" : {
        "fn" : "蔡",
        "gn" : "英文",
        "fnt" : "DOE<JOHN<EDWARD",
        "gnt" : ""

Now… we have to find an vaccine passport app that displays fnt/gnt. Unfortunately, I only found useful apps which show fn/gn… so they will only show my mandarin name. All apps that show fnt/gnt (english/transliterated name) have some caveats…

Greek “Covid Free GR Wallet”: Only in greek, but shows both fn/gn, and fnt/gnt

German “CovPass”: Shows fn/gn, need to go to certificate details to see fnt/gnt

Danish “Coronapas”: Shows fnt/gnt… but can’t save the scanned certificate unless registering,
and shows “Taiwan, Provice of China” :face_vomiting:

Cyprian “CovPassCyprus”: Shows fnt/gnt, but wants a TAN and can’t save the scanned certificate

Irish “Covid Tracker Ireland”: Only fn/gn
Swiss “COVID Certificate”: Only fn/gn
French “TousAntiCovid”: Only fn/gn, and needs to first allow bluetooth based covid tracking
Austrian “Grüner Pass”: Only fn/gn

Polish “mObywatel”: only polish, also needs registration, didn’t try
Scottish “NHS Scotland Covid Status”: Needs registration, didn’t try
Netherlands “CoronaCheck”: Needs registration, didn’t try
Kuwaiti “Immune”: Needs registration, didn’t try

Greek “Covid Free GR”: endless “checking for updates, please wait…”
Spanish “Radar COVID”: Doesn’t have vaccination passport function
Belgian “CovidSafeBE”: Doesn’t have QR scan function

PS: as far as I can tell the current way of using fn/gn/fnt/gnt is still not really the way the fields are supposed to be filled:

It’s now basically showing two completely different names, one (my Taiwanese name in mandarin) in fn/gn and an completely other one (my German name) in fnt/gnt.

Actually, those fields seem to be meant to only refer to the same name: once in original spelling and characters like on the ID card, once in transliterated spelling like on passport.

1 Like

I loaded mine into the Swiss “COVID Certificate” App this morning - and only my Chinese Name shows - in Chinese too!

1 Like

I prefer the German CovPass app.
You can click on display certificates and it will show all personal details including fnt

1 Like

Good to hear that was fixed quickly.

I reapplied for mine to test for regressions. Everything is still the same in working order.

1 Like

And I have loaded my certificate into the German App as well now - and both names show - Chinese name in Chinese, and English name in English.

I will get my Partner (Taiwanese) to download again and then add to the apps as well and see what gives.


Here is an example of old and fixed certificate in the CovPassCheck app


Aaaah! Actually, it seems to be from the CovPassCheck app (the one for people checking other people’s status), and that one shows both names. That’s good. I think we’re all set now, thanks a lot @au !

The CovPass app, which only shows the mandarin name now, is “only” for people like you and me who show their QR code to someone that checks.


Also happy to report that it’s working for me now. On @slawa’s suggestion, I sent an e-mail to @au and some of her colleagues describing the issues, and they responded the next day saying that the fn/gn problem had now been resolved (my full name is now in the “fn” field as Doe John Edward, as on my ARC).

The old passport number was apparently something to do with unsynchronized NIA systems between when I applied for the UI number and when I applied for the ARC, and they also fixed that pretty quickly!

Thanks to @au and her colleagues for their impressively fast assistance with this!


I’ve got the .zip in my e-mail, but every time I try to open it, it asks me for a password? I also got the pdf on my laptop, should I just email it to my self and print it that way?

Is the password maybe your ARC number?

But yeah, printing the PDF should be fine. Or import it into an passport app…

ill give that a try, but I don’t think its the arc number…because I couldn’t even get into my covid certificate with my arc number, I used passport.