Trouble with Internet explorer

I dont know why, but when I view a chinese site the browser insists using encoding for english which gives junk character, but when I go to an english site the browser selects chinese encoding which makes certain characters display weird. Is there a workaround? I tried other browsers like firefox and opera and the problem is worse.

Damn, I haven’t used IE for ages, but there’s a language option somewhere.

Tools > Internet Options > Languages. I think you have to add or delete a language in here. (Maybe Gary knows :stuck_out_tongue: )

Alternatively, you can choose View > Encoding and choose the language you want (auto doesn’t always work) , though this is more of a temporary thing for each page I think.

huh? :slight_smile:

Browser encoding is something I always have to change. Yeah you can specify encoding in IE like irishstu says.

Any well designed site will automatically switch to the right encoding. Too bad there aren’t enough of them.