Typing chinese (software)

Hey,

basically just hope some lovely lad or lady out there can direct me to a place where I can download a program that will allow me to type in chinese … as I have left the island … I know both pinyin and zhuyi fuhao, but it would be impossible for me to type b p m f cause I don’t have a suitable keyboard. Looks like I need to go the pinyin route.

thanks…

Are you running Mac or PC?

Presuming you are using Windows XP.

Go to Control Panel>Regional and Language Options
Click the Languages tap
Check the box for 'Install files for East Asian languages under Supplemental language support
Click Apply and follow the instructions. You may need to insert your Windows installation disc and restart your computer
Return to the Languages tab
Click the Details button under Text services and input languages
Click the Add button
Choose:
Input language>Chinese(Taiwan)
Keyboard layout/IME>Microsoft New phonetic IME 2002a
Click the OK button
Highlight Microsoft New phonetic IME 2002a and click Properties
Click the Keyboard Mapping tab and select HanYu Pinyin
Click OK

You should have a box in the bottom right corner near the clock with the letters EN or CH, if it’s not there
Right click the Task Bar (the blue bar at the bottom of the screen) and select Toolbars>Language bar

Click on the box and select either EN or CH to switch between English or Chinese

I’m running mac. Of course if I had a chinese version of windows I wouldn’t have this problem.

Downloaded NJstar but can’t convert a lot of the emails I get, nor can I read chinese websites. And Chinese windows xp is going for like 350 US$. What the???

help…! I’ll do anything…just say it…

[quote=“baituo”]I’m running mac. Of course if I had a Chinese version of windows I wouldn’t have this problem.

Downloaded NJstar but can’t convert a lot of the emails I get, nor can I read Chinese websites. And Chinese windows xp is going for like 350 US$. What the???

help…! I’ll do anything…just say it…[/quote]

Are we talking about Mac or PC now? :s If you have Windows XP in any language, that’s all you need, simply follow Rik’s instructions. Chinese WinXP just gives you a Chinese user interface for XP, I guess you don’t want that.

(EDIT: solved)

Right now on my new PC when I Ctrl Shift to get Chinese input, I’m only being given bopomofo as a choice. Yuk. I want to type Hanyu Pinyin to produce traditional characters. I tried following the below advice (starting by right-clicking the language bar and going to Settings) and it didn’t work. I’m on XP x64. My tech support can’t help until tomorrow morning, and I’d like to fix it now.

[quote=“Rik”]
Highlight Microsoft New phonetic IME 2002a and click Properties
Click the Keyboard Mapping tab and select HanYu Pinyin
Click OK

You should have a box in the bottom right corner near the clock with the letters EN or CH, if it’s not there
Right click the Task Bar (the blue bar at the bottom of the screen) and select Toolbars>Language bar

Click on the box and select either EN or CH to switch between English or Chinese[/quote]

I did that. I did click Apply and OK and all that. Result:

I do have the language bar with the CH and EN which toggle via Ctrl Shift. But the Chinese option goes through the bopomofo IME.

If you’re running OS X it’s easy. Mac doesn’t ship different language versions of Mac OS - it’s all combined in the one version. So everything you need to type Chinese should be included with your initial install.

Click the Apple menu (top left), then choose System Preferences. Now choose International and then Input Menu. From here you can choose the different input methods - select Traditional Chinese and then Pinyin. Pinyin input is now enabled. To switch between inputs, you click on the little flag at the top right (probably a US or British flag initially) and then select Pinyin from that list. That’s it!

As a side note - the standard Pinyin editor on OS X isn’t that great (but it is free). The best input out there is called QIM, which costs around $20, if I remember correctly - definitely worth it if you plan on doing a lot of Chinese typing.

I miss my Mac. Such settings were so easy, compared with this Microshit crap.

EDIT: For some reason, I selected all the right things but it just didn’t ‘take’. Nam walked me through it this morning. :notworthy: It turns out I needed to remove all but the English, and reboot. Then I just repeated the above steps and it worked. Which goes to show that MS sucks. But we knew that. :raspberry:

I tried this, but I can’t find the Keyboard Mapping tab

so, basically, I have bopomofo, like DB…

would be nice to write with Hanyu pinyin directly in Word

until that works, however, I use NJSTAR and copy the Chinese to where ever I need it

if it’s urgent, DB, maybe you could NJSTAR too, as a temporary solution?

[quote=“hannes”][quote=“Rik”]
Click the Keyboard Mapping tab and select HanYu Pinyin
[/quote][/quote]

I tried this, but I can’t find the Keyboard Mapping tab[quote]

Do you see the language bar? Make sure you have some place you’re typing, like a reply window or Word, and you should see it. Right click on it and choose Settings. This will open a window called Text Services and Input Languages. You should have Chinese (Taiwan). If not, click the other non-English stuff you have that you don’t want, and hit Remove, then Apply. Then Add and choose Chinese (Taiwan) and Chinese New Phonetic IME 2002a (or similar date). Apply that. Then select Chinese New Phonetic IME 2002a (or similar date) and hit properties and go to the tab named Keyboard Mapping, and select Pinyin. Click OK, Apply, Ok or whatever, then test it.

If that fails, reboot and try again. If that fails, reboot, remove all but the US one, reboot, and try again. That should work, and is approximately the same sequence I went through to get mine to work.

Thanks for the NJStar idea, but I got this solved just as you were posting. :sunglasses:

found it, thanks a lot!

Did it work? Are happily typing Pinyin to produce Chinese now?

OK, we recovered the thread. Thanks to the Admin, I am going to try merging it again later once I am sure the glitch has been fixed.

It works just fine. I have been using my win xp system for almost three years now, and I didn’t even know that there is Chinese language support in there. Is there a “print money” function somewhere as well I am not aware of? :slight_smile:

Yes, but only MS execs have access to that function… :smiley: