USB 2.0 ports screwed up by Win XP: any ideas?

Any one got any ideas?

I have three devices: a camera, mp3 player, and multi-card reader all that I attach infrequently to my pc running winxp pro. Recently, they have been giving me much trouble. WinXP refuses to recognize some of them and i don’t know why. Yesterday, it wouldn’t recognize my camera or MP3 player. Today it recognizes my MP3 but not my camera.

I reinstalled windows last night without reformatting the hard drive: it partly solved the problem.

I have tried the devices on other pcs, so I know they are working. It’s definitely WinXP that’s up.

Does anyone else have this problem with WinXP? Why? I thought plug’n’play was the answer but now it’s just giving me buckets of headaches.


My version of XP wouldn’t recognize USB 2.0 until I downloaded and installed Service Pack 1.

Thanks, I already have sp1, and it works with USB 2.0 but only sometimes!


I dunno, then. This is the kind of problem that plagues Windows, and I’m getting rather sick of using computers that have so many such issues. If it keeps up, and there’s no sign it won’t, I might end up not upgrading this computer any more and get a G5 instead.

run windowsupdate and install this update: KB822603 :sunglasses:
described as: “Availability of the Windows XP SP1 USB 1.1 and 2.0 Update”


Thanks for all your support!

I will reinstall Windows XP and back up the partition in future.

Mostly, it’s my patience that’s fried.


You could also try Flashing your BIOS with an update from the vendor’s site…Or maybe even the newer version of your motherboard’s drivers. Can make all the diff.

I’m in Hsi-Chi. If you like you can bring it buy and I’ll take a look at it for ya. email me if your up for it, I’m free on Sundays and do these things out of lack of life. I’ve got a T1 so maybe i can help you find what you need a bit quicker.

Thanks for your help and your offers. I reinstalled Winxp and now some of my devices work again. But my camera doesn’t. I tried the camera in other XP systems, and found it didn’t work ther either.