Why can't I edit my post?

Windows 10, Chrome.
Why am I being prevented from editing my own posts. I would like to fix my spelling mistakes. Yes, I should be more careful but I have severe dyslexia and my spelling tool was not working properly.
I was also prevented from replying to my message on Chrome. I’m forced to use the phone.

Sorry, I’m as baffled as you are. :idunno:

Was the post made a while ago? I think you are no longer allowed to edit after a certain time passes.

It’s 10 hours old.

Maybe it’s a quirk for Windows users.
OS 10 App: Chrome.
I try to edit. Save button doesn’t respond.
At the top I notice a message: What’s your reasoning for editing?
And a text box to fill in.
I enter my reason. Still the save button doesn’t respond.
I choose cancel and it insultingly asks "Are you sure you want to abandon your post/edit.
So, I figured I’d just rant about not being able to edit in the next post.
Same problem.
In Windows on my computer, I am prevented from editing and posting just after I had already posted.
It is a feature or the Forum software would not ask me the reason for my edit.
There are no such restrictions on the Android App.
Is there a true reason not to allow editing?
Legal reasons? if so, most platforms have an edit history option.
Not being able to edit, within a reasonable time is a hardship for people with learning disabilities, visual/motor problems and just people who are bad spellers.
Edit: I just edited just now. I wrote "save button doesn’t respond…’
I forgot my article, “the”.
In Windows or Chrome I couldn’t do this.

There’s a 24-hour time frame in which you can edit posts. Is this happening in all your posts, when you press the pencil icon under the ellipsis at the bottom of them? Or was it a one time thing?

No, this is constant.
It doesn’t allow immediate editing.
It interrogates me as to why I want to edit.
Then it doesn’t allow me to save…
It also won’t let me post another post immediately after the first post.
I detailed what happened step by step. If you like, I will do screenshots.
This is Chrome. Not the Android App

I do not think the software intends to be insulting when it double-checks whether you want to discard your editing. I am sorry to hear you feel this way.

When I have edited posts (my own and other people’s) I typically ignore that question, so I do not think you are required to answer it

It isn’t a legal issue. We have always discouraged the removal of posts mostly because doing so can render downstream posts meaningless. If you remove your own post, you could be suspended.

This platform does have an edit history function, and we use it. Admins have access to earlier versions of posts (so we could resurrect them)


That might help. I’m having trouble envisioning it.

Can I confirm you’re starting this process by hitting the pencil icon at the bottom of your post?

I think it looks like this after you post
@tempogain said this pencil icon will only be available for the first 24 hours from when you first posted


Everything works normally until I hit the save button for the edit.
The button is dead.
Same exact thing when I tried to post a message just after I had posted the previous one.
The save or post button does not respond.
I’ll do the screenshots later today if you think it’s necessary.
There is no issue in your app.
I believe I had the same problem with chrome on Android as well.

When I try to edit, this is what I see. I don’t see anything about an edit reason. Using Chrome in Linux.

Is your Chrome up-to-date?

Correct. I can hit save again and again. It doesn’t save.
That’s the only difference.

When you look in the three vertical dots icon at top right of Chrome, Help, About, what’s your version number?

Have you tried using Firefox? Just to see if it works. It can help narrow the issue.

1 Like

That only shows up if you try to edit after 10 min.
Before 10 min it didn’t even show the icon representing that the post was edited.

1 Like

This happened to me in the past.
I was able to fix that by logging out, closing the browser and getting in again. Have you tried that?

1 Like

Thanks, wasn’t aware of that. Doesn’t apply to us I guess

It does apply to us I think

Edit: no pencil yet

Still no pencil

Any Pencils?

Fourth time’s the charm!

Was wrong, maybe 5th time.

I know about the pencil, but it seems there’s some window to optionally add an “edit reason”?