Win2K and Chinese

In another thread ("What should I buy?), I asked,

quote[quote]Just want to double check on this: If I get an English-language OS (Win2000 or XP), I can view and input Chinese in any program that would otherwise allow it (such as my text editor), not just Office and other MS software? What will I need to do so? Nothing extra at all? A free download of the Chinese IME? Another program I must pay for (e.g. Twinbridge)? Something else?[/quote]
The responses I received made it seem like I’d have no problem, so I bought Windows 2000 (English). And of course I have a problem.

I’ve installed the traditional-Chinese language pack that came with Win2K. I can see Chinese in Web pages and in MS Word. But when I try to open Big5 HTML or text files in my favorite text editor (Notetab), I don’t see Chinese, just garbage characters. Also, when I copy and paste Chinese text into the text editor, the Chinese turns to garbage.

This English-language program works just fine with Chinese in Chinese Win98.

How can I make it work in English Win2K?

yep, Twinbridge or Chinese Star
can do the job

best regs,

Download NJStar .Works with ‘Notetab’.

I doubt that you need to download anything…

Try looking in Regional Options under your Control Panel and make sure that Traditional Chinese is checked (mine is set to default). Otherwise, it could be a problem with Notetab. Chinese displays fine for me in Notepad on Windows 2000 Professional English

The problem lies in ‘Notetab’. Checked it out.

answerer is right:

You don’t need to download any additional software. This works with Windows 2000 and Notetab too. All you need to do is go into control panel, regional options, under language settings for the system, select Traditional Chinese and set it as default. I verified it with Notetab and it’s working.

Hope that helps.

You’re right, no need to download anything, I got it working now.

Set as default? OK, great!

Thanks, everyone. I’m very glad I don’t have to throw money at this problem.

Ok, found the kink again:

You can input Chinese characters but what you can’t do is a cut 'n paste from e.g ‘Notepad’, and vice versa.

Tried it last night 'n forgot about it in the morning.

You might like to take a look at this:

Multilanguage Consultant

When I copy characters from one document and then paste them into another, the characters change
This consultant helps you solve problems you might encounter while creating, editing, and viewing documents containing multiple languages. Just click to answer the questions, and then try the suggested steps to fix the problem.

Select the input locale that matches the text you want to copy

When you copy and paste text, the characters take on the formatting of the current input locale Therefore, if you copy and paste text created using a different input locale, the pasted characters will not be correct. To fix this problem, select the input locale that matches the text you want to copy before you copy the text. For example, if you want to copy Greek text, select the Greek input locale, and then copy the text. When you paste the text, it will appear correctly.

To display non-Unicode programs in their native language

Open Regional Options in Control Panel.
On the General tab, click Set default.
Under Select the appropriate locale, select the language version of non-Unicode programs that will be used.

You must be logged on as an administrator or a member of the Administrators group to complete this procedure. If your computer is connected to a network, network policy settings may also prevent you from completing this procedure.

To open a Control Panel item, click Start, point to Settings, click Control Panel, and then double-click the appropriate icon.

The system locale enables programs that do not support Unicode to display menus and dialogs in their native language by installing the necessary code pages and fonts. However, programs designed for other languages may not show fonts correctly.
Only non-Unicode programs are affected by the system locale. The system locale does not change the menus and dialogs of Windows 2000 or Unicode programs.
The available system locales are determined by the language groups installed on your computer.

good luck!

Two problems I have run into after installing Windows 200 version. BTW I am totally Micorsoft/Windows incompetent :frowning:

First if I set the regional settings to Traditional Chinese and my LOCALE to Taiwan, when my girlfirend tries to look at her emails from hotmail in Chinese… it looks like Chinese but it is not readable… Am I not doing something wrong

Second, I got a WLAN from Chung Hwa telecom via the USB port on a USB card sittiing in the back of the computer. … However after installing the printer drivers and trying to print… a message comes up that the printer cannot be detected… I pushed and pulled on the USB cables and connectors but nothing happens.
Could the LAN be interfering or has the Chung Hwa guy done something to the USB card. The printer worked before on my I MAC

Thanks for any help