Zyxel P-874 to Router

I would like to connect the Zyxel P-874 that ChungHwa Telecom provides to my own router. Does anyone have a guide somewhere or a list of steps on how to disable the DHCP server on the Zyxel and use my own router as the DHCP server?

The simple way would be to connect a LAN port of the Zyxel to the WAN port of your own router.
Then setup your own router as you would normally for it to handle routing & DHCP.

If Zhonghua haven’t changed the default login for the Zyxel, you should be able to go to 192.168.1.1 and log in with ‘user’ as the name and password.

See the info in this thread,
http://www.forumosa.com/taiwan/viewtopic.php?f=7&t=98955&start=80

[quote=“Gary78”]The simple way would be to connect a LAN port of the Zyxel to the WAN port of your own router.
Then setup your own router as you would normally for it to handle routing & DHCP.

If Zhonghua haven’t changed the default login for the Zyxel, you should be able to go to 192.168.1.1 and log in with ‘user’ as the name and password.[/quote]

Thanks for replying. The method you described creates conflicts for the DHCP server. You can’t just plug in your own router and expect it to work.

Can you clarify which settings you have to turn on/off in the Zyxel interface?

I have my own router’s WAN interface connected to the CT modem (which, I just checked, is also a P874). The router is set up to connect with PPPoE, and I also use it as the DHCP server for my own local network. The router also has a DHCP client to retrieve the public address for the WAN interface. No problems whatsoever. I did not need to change any DHCP settings on the CT modem.

I have my own router’s WAN interface connected to the CT modem (which, I just checked, is also a P874). The router is set up to connect with PPPoE, and I also use it as the DHCP server for my own local network. The router also has a DHCP client to retrieve the public address for the WAN interface. No problems whatsoever. I did not need to change any DHCP settings on the CT modem.[/quote]

Thanks for replying Doraemonster.

Few questions:

  1. Do you turn off the PPPoE on the Zyxel?
  2. Do you use any of the other LAN ports on the Zyxel?
  3. How do you set up a DHCP client on the 2nd router to retrieve the public address for the WAN interface?
  4. How do you connect to the Zyxel router’s web interface when you are connected through the 2nd router?
  5. How do you set up DMZ via the 2nd router and then through the Zyxel router? For example, if I have a computer on the 2nd router that I want DMZ-ed, how does that work?
  6. What about a static ip account with CHT Hinet? I can set up PPPoE that’s a dynamic IP through the 2nd router but unable to do it with a static IP account.

Would you mind attaching some screenshots of both router’s web interface settings to show how to set this up?

Much appreciated

Yes. In fact I’ve never turned it off, it was off by default. I use PPPoE on the router.

No. (For the sake of completeness, I also don’t use CT Wi-Fi or POTS.)

For TP-Link (mine is TL-WR1043ND, but it’ll probably be the same for all), there’s a separate section for “PPPoE Advanced Settings,” where you can choose to “Use IP address specified by ISP.” This (somehow counter-intuitively) means you can just type in a static address. If it’s not selected, the router will retrieve the address dynamically.

That’s for TP-Link again. In “Network” > “WAN” you need to set up a “Secondary connection” with “Static IP,” for example like that (assuming you did not change the modem’s default private IP address from 192.168.1.1):

IP Address: 192.168.1.2 (anything on the same subnet should work)
Network mask: 255.255.255.0

I imagine with some other routers it might be enough to add a static route to 192.168.1.1. I’ve just tried it with TP-Link, and (without the above settings) it would not work.

My router’s local network is 10.0.0.0/24. If the above doesn’t work for you, maybe you have a conflict here? The default for many routers seems to be 192.168.1.0/24. You’d be having the same network on both interfaces then.

I’ve never used DMZ, but I imagine since I use PPPoE on the router, on the modem it should just work transparently. Your only problem might be that the external IP address changes everytime the PPP connection goes down. You’d need some way to update the DNS entry as soon as it happens. TP-Link supports DynDNS and some others (comexe.cn, no-ip.org), but for more serious use you’d want to reflash to DD-WRT and set up some more custom DNS update script (for example with XName.org). I’ve never really had the need to do that though. What kind of server are you trying to set up?

I’ve never tried, but I don’t think you can do that. The external IP address changes every time you renew the lease. You can try to keep the PPP link up as long as possible, but you need to expect the address will change anyway.

Not at all:

ZyXEL / Advanced setup / WAN (these are all the default settings):

TP-Link / Network / WAN

TP-Link / Network / WAN / PPPoE Advanced Settings

Thank you! Please post a screenshot of your DHCP settings on the Zyxel as well.

You mean this one? It’s just off:

I apologize for thread-jacking, but you guys know what you’re talking about!
I’m trying to change the DNS server for the router (to use OpenDNS 208.67.222.222 and 208.67.220.220), but I cannot get the changes to stick. After I enter the DNS addresses, when I click either button (it’s in Chinese), it goes back to 0.0.0.0.
As a side note, how did you get an english interface? Is there a firmware update I can do? I couldn’t find anything on the Zyxel website.

That interface, the Englishy “advanced” one is only visible when you http to the external (WAN) IP address.

When you http to internal address (for example 192.168.1.1), you get the Chinese and simplified menu.

Interesting…I can connect (using my dynamic IP), but it won’t update that way either. Actually, when I hit “Apply” it does something and I get a new IP.
And it’s still Chinese - is there a switch to get the English?

My guess is you are doing something wrong (suggest you post a screenshot).

You could also try downloading the modem configuration file, editing it with a text editor and then re-uploading it to the modem.

Don’t worry, my IP address will change as soon as I try to apply (left button I learned) new DNS settings, so I’m not inviting everyone to access my router!
https://docs.google.com/open?id=0BwuIeaYxaoY1OUFYaFN6cEoySjQ
https://docs.google.com/open?id=0BwuIeaYxaoY1bjJHWlN1V2FocVk

Trying to d/l the config file via ftp, but it seems typical ftp commands aren’t working (“500 Unknown command: “LIST”” when I type ‘dir’ or ‘ls’). Will keep trying!

Anyone have problems opening ports with the Zyxel p880? When I first got the connection I opened up ports and with soulseek and utorrent both programs would say ports are open. Now even with the same port forwarding options they both show closed. Anyone know what’s going on?

Can anyoneo on CHT check to see if their ports 6015 and 20904 are or can be opened? I think CHT has started to block them for me.

[quote=“thirdstring”]Don’t worry, my IP address will change as soon as I try to apply (left button I learned) new DNS settings, so I’m not inviting everyone to access my router!
https://docs.google.com/open?id=0BwuIeaYxaoY1OUFYaFN6cEoySjQ
https://docs.google.com/open?id=0BwuIeaYxaoY1bjJHWlN1V2FocVk

Trying to d/l the config file via ftp, but it seems typical ftp commands aren’t working (“500 Unknown command: “LIST”” when I type ‘dir’ or ‘ls’). Will keep trying![/quote]

Your modem is getting that DNS info from PPoE. You cannot disable this though the simple menu.

For the advanced menu, http to the external side (WAN’s ip address), and log in with user: cht / pass: chtnvdsl
(this password for north taiwan only, for south use chtsvdsl or for central, use chtcvdsl)

DNS> uncheck “obtain DNS from WAN interface”
Management>reboot

should work :cactus:

I forgot to ask why you want to change your DNS. That needs to be pretty low latency if you want web pages to load in a reasonable time. If you are in Taiwan, CHT’s servers would obviously offer far better performance compared to DNSs overseas.

Thanks for your help. I was trying to login to the external side using the user/user login, which gave me the basic menu. I also had to use the North password, as the central didn’t do it.
The interesting thing is I uncheck the box, click save/apply (or click on the management tab immediately), and the check always reappears. In short, it won’t keep my DNS settings. But now that I can get in (big thanks!), I should be able to play around and figure it out. Though I did just try editing the config file directly and it still changed back after uploading it…

Trying to get OpenDNS as a basic filter on the network. I thought it would be easier to change the router than individual devices. And less chance of the kids changing the settings!

Does anyone know the correct way to put the Zyxel P874 into bridge mode, so it can be used with a separate router?

The above example makes no sense to me, as the P874 is still in PPoE mode!

It’s pointless to have a double router setup, because some functions of the new router won’t work unless the router faces the internet directly.

Thought I’d share what I learned for those who still wonder how to put p874 in bridge mode.

Login to the router and go to “quick setup”. Under settings for WAN you can choose “bridged mode”. Choose this setting and click ok. Beware, your WIFI and internet connection will be immediately lost since the routers setting will disappear. Now you’re free to use whatever method to connect to internet that you choose.