Alien Citizen Digital Certificate

(Starting a new thread as couldn’t find an appropriate existing one to tag this question onto.)

Has anyone applied for the Alien Citizen Digital Certificate lately? I took my ARC to the NIA yesterday afternoon to start the registration process, but the MOICA website doesn’t seem to want to let me log in to make the payment - after I enter my ARC number and the code given to me by the NIA, I just get a “no information” message and don’t seem to be able to do anything.

I’ve read a couple of blog posts on the application process but I’m none the wiser (they seem to skip the details of the payment step). How long did it take between getting the code from NIA and being able to make payment on the website?

I think it’s kind of weird that you can not pay when applying, you need to go apply first than access the site and pay.
I applied a few years ago but missed the window for paying online, like two weeks or so. Never got my certificate.

Yeah, I think so too, but…it is what it is. Have you done it recently?

I seem to remember reading it’s necessary to wait until the next working day or something before paying, but it’s the next working day already and I still don’t see an option to pay. :neutral_face:

No, I don’t want to go to the NIA. Too cumbersome.

When I applied, I think it worked within 24 hours. Looks like I got further than you did with that particular website, but it definitely has issues (the card activation function flat out did not work). The folks at 0800-080-117 know what they’re talking about and are very friendly - perhaps give them a call?

3 Likes

Does this digital citizen certificate take us one step closer to facial recognition monitoring by AI?

Perhaps, but even then I suspect it’ll only work in Internet Explorer 6 and below and not with foreign faces, so we should be fine for a while.

3 Likes

I got one recently, applied in the morning and was able to pay that night, they do say 24hrs or something like that. Make sure you retain the piece of paper they gave you as you need the temporary user name on that. I was able to activate it online but only on the Chinese version of the website, the English version wouldn’t load correctly.

2 Likes

Thanks for your input. But…hmmm…what do you mean by Chinese and English versions?

This is the website I’ve been trying to use, the one that comes up when I go to https://moica.nat.gov.tw/ and choose the “Aliens Citizen Digital Certificate” option:

Choosing “Application Progress & Payment” takes me here:

And entering my ARC number and code from the NHI is what gets me to the screenshot I posted above saying “no information”.

Is that what you did, successfully, or were you using a different website? (Calling either of these an “English version” might be a bit of a stretch… :sweat_smile: )

That’s the bit for checking progress I used as well. How long has it been since you placed the application?

Actually activating the card comes later after you receive the card, it’s a new level of hellish website design, that’s the part that only seems to work in the fully Chinese section.

I applied at NHI on Thursday afternoon, so one working day so far. I guess I’ll try again on Monday then go back to NHI if it’s still not working… :face_with_raised_eyebrow:

Give them a call if you don’t see it on Monday, I was surprised how fast mine came through. Make double sure the correct ARC number is on your receipt and that you’re entering the user name correctly, it’s case sensitive.

Yeah, it’s still not working for me. I went back to NIA on Monday to reapply and get another code, but that also doesn’t work - same error message.

Am I correct in assuming that the customer service number is Chinese only?

Thought I’d give an update on this in case anyone else runs into a similar situation.

The issue in my case was that NIA apparently hadn’t passed my address onto MOICA for some reason (not sure why, but NIA definitely do have my address from my gold card application earlier this year). As a result, when I tried to log in to the MOICA website to pay for the card, the system wasn’t finding my information.

I did go back to NIA a second time to get a new code (also didn’t work, and they couldn’t really help me beyond that - just suggested I call MOICA if the same problem happened again). I also sent an email to MOICA at some point but they didn’t answer (probably because it was in English). Finally ended up getting my girlfriend to call them (the “press 2 for English” option (spoken in Chinese) didn’t seem particularly useful, since it just played a recorded message telling the listener to go to the MOICA website or send an email to the address they didn’t answer me at :roll_eyes:).

Anyway, MOICA contacted the NIA and then called me back to ask me to email through my address, which I did, then they updated my records so I could finally pay to get the card sent out. So seems to be sorted now. :slight_smile:

5 Likes