Google Blogger/Blogspot - language settings

Does anyone know how to change the language settings on blogspot?

I had a blog there once (don’t anymore) and it was set up with English as the default. But just now it seems, when I tried to make a comment on someones blogspot blog, everything was in Chinese, and I can’t find a way to turn it back to English.

It’s probably really obvious what to do, but I can’t find it, because I can only read about 50 characters in Chinese.


If you’ve got gmail, log in, then go to blogger. Should be the third option on the upper right.

Even that is not a sure fire way to resolve the language issue.

I am virtually logged into my gmail whenever I am online, and even if I log into my own blog, it comes up in chinese.
If you hover over the links down the bottom while keeping and eye on the bottm left status bar, you’ll see language come up (this is really odd as normally Google sites have a ‘Google in English’ link, in english -HA)

It’s not just blogger that this happens too. It’s bloody annoying. Cookies don’t seem to hold the setting from day to day either (Firefox for me at least).

3rd option on the upper right signs me out (I think). Whatever it’s doing, I’m still not getting English.

Truant, didn’t see your post until after I’d replied. What you said worked, I managed to get things into English. I took the long way though - my status bar is permanently hidden (I love keyboard shortcuts) so I had to click all of them until I found it.

But it worked in the end, so thanks for that.