Image uploads not working

works for me

Nope. No joy for me. Had to transfer from iPhone to desktop via LINE app.

Are you using iphone or ipad?

Never Mind. Not directed to me. Oops.

@MalcolmReynolds, what’s the filetype of the photos you are trying to upload?

HEIC format by default” and probably not supported, you need to change to JPG.



1 Like

You see, that is total bullshit!

I have been able to upload pictures directly from my iPhone and my iPad since forever. Suddenly, without changing anything on my iOS devices, I can no longer upload photos.

I have never had to concern myself with the HEIC format versus JPEG format. I’ll take a picture, I upload it. Now it’s not working.

You are probably right that HEIC is the standard iOS format for pictures, but why should I have to change anything if it has always worked in the past and suddenly it is not working?

This is most likely another problem with “wonderful” Discourse and how it interacts with the web browser Safari of iOS. It’s the same thing with the screen Jank on desktop computers. Everything worked great and without changing anything suddenly it doesn’t work.

These problems are so stupid and frustrating and almost always occurs because of a software update of some kind

1 Like

Iphone didn’t always have HEIC. Only since iOS 11

so only since 2017

Cool story brother!

But, I have been running iOS 13.6.1 since it was released on August 22, 2020 and have not had any issues uploading pictures in the past. I absolutely will not update the system on this old phone any higher.

Nothing has changed on my end. Nothing. But now I can’t upload photos from my mobile iOS devices since a few weeks ago.

Anyway…time to slop the hogs and do my evening chores.

Don’t bite me!

1 Like

I think I fixed it. Give it a try.

Thanks @Belgian_Pie for pointing out the issue.


Hey everyone,

After the overnight “upgrade” of Discourse I can now successfully and without any issues upload images from my iOS devices.

The problem was the previous “upgrade” of Discourse which rendered my iOS devices unable to upload images.

I did some troubleshooting on all iOS devices and here are my findings:

Here is a list of all the iOS devices that I tested BEFORE this latest and greatest Discourse update last night.

None of these devices could upload any images to Forumosa before today.

Iphone 6s Plus - iOS ver. 13.6.1
Iphone 6s Plus - iOS ver. 12.3.1
Iphone 6 - iOS ver. 12.5.5
Iphone 6 - iOS ver. 12.4.2

Ipad Air 2nd Gen. - iOS ver. 13.6.1
Ipad 3rd Gen. - iOS ver. 9.3.6 - MAX iOS

Ipod Touch 7th Gen. - iOS ver.12.3.1
Ipod Touch 5th Gen. - iOS ver. 9.3.5 - MAX iOS
Ipod Touch 4th Gen. - iOS ver. 6.1.6 - MAX iOS

The problem seems to have been the iOS versions on my devices. For some reason Discourse would only allow iOS devices to upload images that had an iOS version ABOVE 13.6.1. I would assume that the version had to be iOS 14.0 or above in order to upload images, but I didn’t have any with anything higher than 13.6.1. How did I come to this conclusion?

I borrowed my PA’s Ipad and tried to upload an image yesterday without any issues! So, it must be assumed that all of my devices couldn’t upload images because they were below the suspected requirement of 14.x iOS version or higher!

iPad Air 4th Gen. - iOS 14.6 - IMAGE UPLOAD SUCCESS

Further research. I contacted one of our esteemed members who has two iOS devices and he was able to upload images yesterday utilizing both of his without any issues. He was even able to upload images using his older iPhone 6 with the iOS ver. 15.2.

Iphone 12 - iOS ver. 15.2 - IMAGE UPLOAD SUCCESS
Iphone 6 - iOS ver. 15.2 - IMAGE UPLOAD SUCCESS


This whole unable to upload images debacle had absolutely nothing to do with my iOS devices, nothing to do with the size of the images, nothing to do with the type of the images, nothing to do with the browsers used.

It merely was some bug in the previous Discourse update (or it was intentional) that wouldn’t allow any image uploads based on the devices iOS version. Basically, if you had any iOS version less than 14.x, you were screwed and couldn’t upload any images.

Thanks to all that tried to help me get sorted.



I have never liked Discourse since the beginning. For me, Discourse is designed for the next generation of phone zombies for easy scrolling and overall ease of mobile use. As far as I’m concerned, there was only ever one single thing about Discourse that I liked over the phpBB system. The ability to directly upload pictures to the site and not waste time linking images from external hosting sites like Photobucket. That is an awesome function. However, I’m guessing that phpBB could also allow direct uploads as well if the site administrators would allow it.

Collusion with smart phone makers and app stores?

I’m so sick and tired of getting the nag screen to update my iOS to the latest and greatest version. Each new version is more bloated than the rest and merely slows my older devices down to the point where they become nearly unusable. Also, many popular apps that we use are constantly updating and sooner or later you must update or you can no longer use the app. But, when you go to update the app to the newest version, your old device can’t download or use it because your device also needs the newest iOS version! But, then you find out that you can’t upgrade your device to the newest iOS version because the chip won’t support it. What’s the option? Buy a brand new smart phone for $50K if you want to use the app. I believe that these actions are deliberately created by the tech industry to force you to purchase the latest and greatest product…$$$$$$$$!

My older devices such as my Ipad 3rd Gen. can’t use the LINE app anymore because LINE no longer supports older versions of their app and my Ipad 3rd Gen. can’t upgrade the system beyond the max version of 9.3.6.

Older devices which are still in good running condition are rendered obsolete by the inability to run the Youtube App, LINE App, Google App, Iheart Radio App, Pandora App, etc. The list goes on and on. A perfectly good piece of tech rendered obsolete in order to force me to purchase the latest and greatest device. Total fucking bullshit! I have four iPhone 4 which are now only usable as portable MP3 players as they’re not good for much of anything else although they function fine.

More Discourse woes

During my testing I also found that some of my devices can’t even see the Forumosa site because of Discourse! Yeah, that’s right. Ipad 3rd Gen, Ipod 4th Gen, Ipod 5th Gen. can’t log in and can’t even read any of the forums. Yeah…Discourse is in cahoots with Big Tech in order to make us spend more money to keep up with what they determine we should purchase.

Why didn’t I update my Iphone to iOS 15.x in order to post pictures on Forumosa?

Because, fuck that shit. I will not be forced to update my system or purchase a new device in order to become a fuckheaded phone drone and participate in a derelict website such as Forumosa! And, as you can see, the newest, latest and greatest Discourse update has remedied the problem. The first thing I saw this morning posted by @tempogain was that the Discourse had been updated, so I just had to see if I could post an image successfully without doing anything different on my end. See? Just as I suspected. It was Discourse all along and had nothing to do with me or my devices and by sticking to my guns, I avoided the unnecessary and mostly unhelpful iOS system update!

Ha. Take that!
Tiger Blood & Adonis DNA

Malcolm Winning

If you bothered to read my entire post, to include this self-important whinge of a rant, then give me a fuckin’ like for this epic post!

If ya’ll are good, I’ll post more north coast beach pictures because now I can.

For now, I’ve got to go. I’m headed down to Taipei to the Apple Store to purchase the Iphone 13 Pro!


On iPhone, if I use Safari to create a web app of Forumosa on my homepage, I cannot upload images with it. When I click the upload file button nothing happens. It works fine if I open Forumosa normally in the browser.