Image uploads not working

I’m trying to upload some images in the daily photos 2021 thread and they won’t get uploaded.

Seems to work for me, can you tell me anything specific about your phone or the images? Are you sure you had internet at the time?

I think we’re blocking Snapseed edits :joy:



What do you mean?

It’s from PC.

What’s the formatting on the images? How big are they?

1 Like

Same size as always.

What size is that?

Never mind, I can see on your old images.

I can’t see anything that would cause problems in our settings. What exactly are you seeing when the problem occurs? An error message, or what?

It just keeps ‘processing upload’

Seems to be Google Chrome problem, just used Edge to upload.


I was just going to ask, do you have the latest Chrome version? That’s known to cause problems after a Discourse update (we just did one).


1 Like

I uploaded the image above on Chrome 96.0.4664.45. Please post back if it continues after a couple of days?

Over the past week I have been unable to upload any images from my mobile devices. In the past, I have routinely uploaded images using my iPhone 6s Plus and my Ipad Air 2 without any problems.

The images are not too large and I’ve worked around it by uploading the exact same images using my desktop computer or my notebook computer later after returning home. It’s a real pain in the ass.


  1. Take a picture of Baishawan Beach with my Iphone 6s Plus.
  2. Attempt to upload it to the Forumosa site. It gets stuck forever on “processing”.
  3. Go home and transfer the picture from my phone to my desktop computer.
  4. Upload it to Forumosa.

Major drag.

Nothing has changed over the past week in terms of my Iphone or my Ipad. Just suddenly and without clear reason, I can no longer upload images from my mobile devices.

Couple this with the well document Screen Jank using desktop computers and it really gets frustrating trying to contribute to this site in a meaningful way.

Here’s a picture of my weather station I first tried to upload via my iPhone and it failed.

PROCESSING UPLOAD…forever and it never succeeds.