Linux Idiot...!

“KNOPPIX is a bootable CD with a collection of GNU/Linux software, automatic hardware detection, and support for many graphics cards, sound cards, SCSI and USB devices and other peripherals. KNOPPIX can be used as a Linux demo, educational CD, rescue system, or adapted and used as a platform for commercial software product demos. It is not necessary to install anything on a hard disk. Due to on-the-fly decompression, the CD can have up to 2 GB of executable software installed on…”

How on earth do you get your pc to boot from cd-rom? I tried to enter bios setup and set cd-rom as the first in boot sequence, but nothing happens!

i.e. I enter bios, set cd-rom, save setting exit. Reboot pc. CD rom starts whirring. Next thing I see is Windows 98 booting up again.

What am I doing wrong? Am I missing something?


Your CD-ROM drive might not be bootable. My understanding is that some aren’t, especially if they are older. I can’t say for sure, since the only times I’ve tried booting from them were with my current, eminently bootable, drive.

Bad workmen blame [his:edited] their tool…


Ax, were you drawn into this thread by the second word of the title?

Win98 means you can run dos. Do so and then go C:cd/(cd drive letter)

Type (driveletter)setup or autorun

[quote=“ax”]Bad workmen blame his tool…


Since I’m neither ‘bad’ nor ‘working’ I can only presume that the aphorism applies to the poster himself! It would be nice if you could get your grammar right before you slag someone off.

Kenneth :smiling_imp:

[quote=“Alleycat”]Win98 means you can run dos. Do so and then go C:cd/(cd drive letter)

Type (driveletter)setup or autorun[/quote]

Wow! Thanks! I will certainly give that a try. I did look at the cd rom on one machine, it’s certainly old. The other however was brand new.

I think the problem lies in the setup with Bootmagic!

Anyway! Thanks again.


I tried that solution for running the Knopper 3.2 but it didn’t work.

When in Dos mode, my cd rom driver isn’t loaded so I can’t access the cd rom!

What should I do? Thanks


Do you have a floppy drive? If so, create a start-up disk.

Run from the floppy. From which you can format C etc. Then run setup.exe on the CD. You start-up floppy will have the CD driver.

You need to check your BIOS settings. Make sure your CD Rom is set to bootable. I believe some cannot be booted from. BIOS setting can usually be checked by restarting and holding down the delete key at boot up or whatever key it tells you (very briefly!) to press.

Some useful info:

I had many problems when I used Bootmagic with XP and eventually removed it.

I could use some help with my linux install.

Setup: Suse 8.1 personal dual booting with WinXP

Problem: the HID USB internet Compaq keyboard does not work in Linux bootup nor in KDE, Gnome etc.

I get messages like “bulk timeout”

Compaq has been unhelpful and Suse avoids blame. Some online users have suggested changing some kernel lines, but doesn’t seem to work (plus I dont know what I am doing).

I’d rather not go out and buy a PS2 keybd just for this (although I know it works having borrowed one)