Portable HD not registering

Strange. We bought a 80GB external HD. When we plugged it into the USB port, it warned us that the USB port isn’t fast enough(which shouldnt affect too much)

BUT, even though it appears under the ‘safely remove’ thingies, it doesnt open as G and H drive.(its devided in 2)

It works on my laptop, and on other peoples desktops. We are using Windows XP 2000…it should just pop open?! The light on the external HD goes red right after we plug it in.

any ideas?

The hard drive may not be formatted properly. I just had the same thing happen to me. Exact same situation as what you described.

I used Partition Magic to format my external HD, and after that, it worked great. On my Windows 2000 computer, the drive window will pop open when the drive is recognized. Not sure if that would work on every computer, depending on your settings.

Edit: Sorry, I missed the part where you said it worked on other computers. I didn’t actually test mine on other people’s computers, so I don’t know if my situation was exactly the same as yours. In any case, formatting my drive helped, so I’m happy.

Hey Battery9. Have a look at this thread and get back to us:
[forumosa.com/taiwan/viewtopic.ph … highlight=](External Hard Drive installation question

Ended up updating USB and its working:)