QIM - best Hanyu Pinyin input for OS X

When I made the switch from Windows 2000 to OS X, the one thing that really bugged me (besides the lack of a version of Rawshooter Essentials) was the crappy IMEs for Traditional Chinese.

The IME that I used with Windows to input both Traditional and Simplified Chinese works just the way I want: I could type in strings of 詞 (words) at a time in Hanyu Pinyin, seperate them by spaces, and the IME would do such a good job of guessing which word I was trying to write that I’d only have to occcassionally go back and correct it. So if I wanted to type the word 資本主義, I could just type “zibenzhuyi” straight and it’d appear correctly. Moreover, it does a fairly decent job of memorizing, so that characters you frequently type in tend to come up first. It also does a good job of remembering and automatically outputting names and loanwords.

It’s a whole other story on OS X. There are two IMEs included with OS X that use HP for Traditional Chinese output: Pinyin and Hanin. Pinyin is completely unusuable. First, you can not type 詞 at a time. That is, if you want to write 資本主義, you have to type “zi,” stop to pick out the 資, type “ben,” stop to pick out the 本, etc. If you dare try to type “ziben,” the computer will beep at you when you press b.

After two minutes of this, I was ready to throw my shiny new iMac out the window. This is a gigantic pain in the ass, especially if you’re typing a word with “ji.” The Windows version can usually guess which “ji” you’re going for by looking at the 詞 you just typed in. But through OS X’s Pinyin method, you have to wade through several pages of “ji”'s, which could take forever.

Hanin is a bit more usable, but still much slower. You don’t have to stop to guess until you input a entire 詞 and it does use the other character in a 詞 to guess a certain character. But you still have to unnecessarily input a space after each character, it doesn’t remember names/loanwords, and worst of all you are required to input a tone number after each character. Thus to enter 資本主義 , you’d have to type “zi1 [space] ben3 [space] zhu3 [space] yi4” and then go back and change 主意 to 主義.

To be 100% honest, my tones are rusty enough that this slows me down. :blush:

Interestingly enough, the ITABC IME for inputting simplified Chinese in OS X works pretty much the same as the Windows version. So I’ve been using this to type in simplified Chinese to chat on Yahoo with some of my Taiwanese friends. Not the way to impress the honeys…

But I recently found QIM, a third party IME that absolutely kicks Pinyin and Hanin’s butt at inputting traditional Chinese. It was originally made for simplified Chinese, but you can change to traditional Chinese easy enough. Here’s how to install it.

1.) Download QIM from this page: sinomac.com/QIM/index.php If you can’t read the page, you have to enter your email address, name, online handle in the three text boxes; choose where you’re downloading from the drop down menu (note that the bastards say 中國台灣 for Taiwan); and then hit the button to download.

2.) Install it. It’ll ask for your root password and you’ll have to reboot.

3.) After restarting, you can add QIM to your IME list by going to System Preferences → International → Input Menu and then checking QIM in the list.

4.) QIM is initially set up to output in simplified Chinese. To change it, choose QIM from your IME menu, go to QIM 設置…, then you can choose Output in Traditional Chinese (Big5), and hit OK.

Voila! I can finally type “zibenzhuyi” straight and it correctly outputs 資本主義. Hallelujah!

Thanks. I’ll have to check it out. I don’t do much pinyin or any Chinese. :slight_smile: Though I like Wenlin when I do try it.

I haven’t looked into raw tools for the Mac. I think many people prefer Capture One and consider it worth the price.

I’m really looking forward to Aperture. Eveything I hear about it is amazing. One person said at the very least it will be remembered for forcing everyone to get better. It does things no other tool has done before.

Pro photographers can come back with several hundred photos from an afternoon shoot. Choosing selects can take hours.Not so with Aperture. It really is the first tool that pro photographers will really use. I think they asked people what they used to organize and many people said nothing at all, cuz everything is bad. Until now.

I’m now starting to really learn Chinese. For typing pinyin, I’m trying out what’s built into OS X (ITABC for simplified), openvanilla, and QIM. QIM is very interesting.

I’m not sure what to think of tone marks. People say they type pinyin without tone marks and it’s faster. Could be. While I’m beginning, tone marks are very helpful at the moment. QIM works by tabbing. Tab twice to see the characters with tone 2. Openvanilla I can’t seem to find it. Is it there? ITABC: Not sure if you can use tones. (I’m using simplified since I’m considering moving to China). For traditional, Hanin pinyin (instead of pinyin) lets you use tone marks.

For selecting different characters, space bar with Openvanilla lets you scroll thru all the characters and you press a number to select one. QIM uses comma and period which is a bit slower.

QIM shows possible characters after just one character. It filters as you type more.

Frequency of use: QIM seems to put the last used first. Others I haven’t tried much.

Remaining in one input method: QIM lets you toggle English or Chinese with one keystroke. Others seem to require you to return to English input method.

So I’m trying them out all for now. I’m curious if anyone has thoroughly used them all.

Voila! I can finally type “zibenzhuyi” straight and it correctly outputs 資本主義. Hallelujah![/quote]

All the input methods I’ve tried let you do that (though they’re probably progressed since your post date).

QIM and ITABC (seemingly no for built in traditional hanin or pinyin) let you simply type the first letter of each character, for instance zzbj for zhūzǐbǎijiā.

I just installed QIM and it works lovely. Being able to type hjbj to get 好久不見 is pretty fusking sweet. Things seemed to have locked up during the reboot, but I have a feeling that it might have something to do with me not currently having the power in.

Thanks for this post.