Youtube Keeps Getting Redirected

My bookmark says with the Chinese interface. I’m using IE and English Windows. It happens on XP and 2000.
One time I deleted all my cookies and that fixed it for a while. I wonder what I can do to stop it.

And I’m not switching to Firefox.

In the top right, it says “site” and a little flag, click that to a non squiggly country. If you delete your cookies it will default to Taiwan because you have a Taiwan IP.

And switch to Firefox.

And drink decaffeinated coffee from now on.

At the top right of the page, you’ll see a Taiwan flag. Click on that and you’ll see a drop down of flag icons as well as a circle icon. Choose the circle icon. That is the global site.

Edit: Beat to the punch.

Thanks guys. It’s one of those user-friendly things.
It’s so obvious.
Firefox wouldn’t help.
I’m going to sleep now.

It wasn’t so obvious because it said “site” in Chinese which isn’t much help.

I was wondering if the Taiwan version might be situated in Taiwan and be faster. I tracerted it and it isn’t. has the same IP address as

It isn’t so obvious if the javascript file doesn’t load and such the drop down menu doesn’t work.