2.0 software update for Iphone 2g/ipod touch CRACKED

Confirmed and working on my previously v1.4 Iphone 2g!

Download the new Pwnage tool here:

blog.iphone-dev.org/post/4285831 … qus_thread

Download the bootloader files here:


Download the newest firmware here:

appldnld.apple.com.edgesuite.net … store.ipsw

Here’s a guide for the install procedure:


But we can’t post about movie torrent DL’s on here…right?

Not allowed to promote illegal activities. This is against company policy, but whether or not it’s illegal is a gray area.

Believe it or not, in the states, hacking a phone to allow for usage on any network is protected by copyright law. So there’s nothing illegal about this at all.

blog.wired.com/gadgets/2006/11/u … ht_to.html

make sure you set some free time when you upgrade, I was in a rush today getting it upgraded and got it working to 2.0, then clicked on cydia for critical updates, it was taking forever and I was late for work so leaving my house meant no more wifi, it just stuck at the dowloading/installing…rebooted the phone by holding the sleep button for about a minute and it booted back up ok. But after clicking on cydia it said it was updating and not to turn off, well, auto lock kicked in, so i hit sleep again to wake it up and then bam…everything is gone, no buttons, only a youtube icon, no icons on the bottom, nothing…I cannot make any calls, no imput nothing…thankfully I’m still able to receive calls.

As I am at work and no access to my mac, I will have to wait till I get home and hopefully be able to restore the firmware fingers crossed

So, just a warning…make sure you have enough spare time and if not just leave the phone at home to update.

Although, maybe it’s just my luck, but I figured I’d give a warning in advance.

update…got it to restore, went to cydia and selected the essential updates…same as before, it gets stuck at ‘downloading apt…’ i’m reluctant to reboot it, i guess i’ll give it an hour or two, anybody else having this problem??

I’m gonna hold off for a bit. Each time I went to 1.1.2, then 1.1.3 then 1.1.4 I’ve waited for a bit longer after the crack is out cos invariably there are some minor bugs that get patched in the few days after.

Who cares about what’s legal in America? Is it legal here?

Since the iPhone is not offered in Taiwan it’s hard to imagine that it would be illegal somehow. Probably comparable to cracking your DVD player to make it multi-region.

Since the iPhone is not offered in Taiwan it’s hard to imagine that it would be illegal somehow. Probably comparable to cracking your DVD player to make it multi-region.[/quote]
Oh my GOD! So you’d be nothing more than a common criminal, then? Fire and brimstone, that’s what’s in store. Mark my words. Fire and brimstone, you bunch of crackers, you!

all previous apps will be gone too

i think i liked installer better, this cydia is really driving me mad, maybe the servers are overloaded since the hack just came out yesterday.

i ended up just resetting it, went to dinner, came home and tried again, now it’s stuck at ‘downloading coreutils…’ :fume:

the thought of being without my iphone for even 20 mins during waking hours just gives me the shudders.

i know the feeling, to think all day at work I had a crippled iphone…i was actually thinking about hitting the nearest tsan kuen to pick up a temporary phone.

…and yes…it’s still ‘downloading’ :frowning:

.edit…given up on cydia for the time being, grabbed some free apps off itunes, nice games on there, like tap tap (sorta like guitar hero), overall, 2.0 is pretty nice! would recommend the upgrade if you know what you are doing, just stay away from updating cydia for the time being since it is so so slow

Well screw that!
I’m not going to risk losing iZoo!

Well sandman, it may come as a surprise to you that the servers for Forumosa are located in the good old US of A. So as to whether or not a particular thread is legal or not, it would be American law that applies.

But also because America is the most important country in the world, particularly more important than say, Scotland. :wink:

Well screw that!
I’m not going to risk losing iZoo![/quote]

:laughing: Especially with the Chuzzle theme.

they actually have some really nice games in the app store and some are free, i’ve only downloaded a couple, pretty nice. I’m sure iZoo will be ported to 2.0 soon, either that or it would be available for purchase only.

back to cydia, i did the update before bed and woke up this morning, yup, it was still downloading :fume: and everytime i hit it there’s more and more ‘essential’ updates added :raspberry: i’m just gonna give up on it, it’s making me :loco:

all these talk about legal, illegal made me read the iphone agreement found in ‘settings-about-legal’, since it’s based on BSD and GNU, it’s perfectally legal as long as copyright notices are included in the release, which it is since I see it on the cracked 2.0, so let’s just talk about the new firmware k? :smiley:

Update on my Cydia progress…

This morning I got Cydia to install the updates fine, but I tried a different approach. Instead of clicking on ‘upgrade essential’, I decided to select ‘ignore temporarily’. Then I clicked on the ‘changes’ and selected install all, this worked like a charm and took less than 5 minutes to download and install.

Now, I had noticed before by doing the automatic essential upgrades that the time was frozen, i.e. I set it to update at 12:53am and wake up in the morning and the clock is still at 12:53am. I also noticed that doing the upgrade route that the screen goes blank and comes back online within the first minute. So, my guess is that autolock kicked in and when cydia woke it back up, it freezes hence not able to complete download and the freeze. I could be wrong.

I wish some of you guys would take the plunge and try to upgrade it so I can find out if that’s the case or just me. :slight_smile:

three - I had the same problem. Also fixed it by “ignore temporary” and installed the upgrades manually. Seems to be a bug in cydia.

Does anybody have problems with the international caller ID on FW 2.0.(1)? When somebody calls me, I only see the number, allthough caller is in my addressbook. I have found a link where it explains how to fix it for some countries, but not Taiwan. I have been trying to edit and experiment with this file but it does not seem to work.

bollywoodtadka.com/2008/07/24/ca … countries/

According to this I added to the file:


886 <— Country Code
00 <— Zeros at the beginning of an international Number
1 <— Zeros before a local number
2 <— This is the length of the prefix number (denoted by x)
8 <— This is the length of the actual number(denoted by y)

But it did not work. Any ideas?